目录

CF1395A-Boboniu Likes to Color Balls

CF1395A-Boboniu Likes to Color Balls

题目:

题目描述:

Boboniu gives you

  • $ r $ red balls,
  • $ g $ green balls,
  • $ b $ blue balls,
  • $ w $ white balls.

He allows you to do the following operation as many times as you want:

  • Pick a red ball, a green ball, and a blue ball and then change their color to white.

You should answer if it’s possible to arrange all the balls into a palindrome after several (possibly zero) number of described operations.

输入格式:

The first line contains one integer $ T $ ( $ 1\le T\le 100 $ ) denoting the number of test cases.

For each of the next $ T $ cases, the first line contains four integers $ r $ , $ g $ , $ b $ and $ w $ ( $ 0\le r,g,b,w\le 10^9 $ ).

输出格式:

For each test case, print “Yes” if it’s possible to arrange all the balls into a palindrome after doing several (possibly zero) number of described operations. Otherwise, print “No”.

样例:

样例输入 1:

1
2
3
4
5
4
0 1 1 1
8 1 9 3
0 0 0 0
1000000000 1000000000 1000000000 1000000000

样例输出 1:

1
2
3
4
No
Yes
Yes
Yes

思路:

实现:

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
#include <bits/stdc++.h>
using namespace std;
int main()
{
    int n;
    cin >> n;
    while (n--)
    {
        int a, b, c, d;
        cin >> a >> b >> c >> d;
        if ((a & 1) + (b & 1) + (c & 1) + (d & 1) == 2)
            puts("No");
        else if (a == 0 || b == 0 || c == 0)
        {
            if ((a & 1) + (b & 1) + (c & 1) + (d & 1) == 3)
                puts("No");
            else
                puts("Yes");
        }
        else
        {
            puts("Yes");
        }
    }
}